Jump to content
Muxe Inc Forums
Sign in to follow this  

Control key not working in Linux

Recommended Posts

dandv    0

I'm running NDN 2.30.0024/ENG under Linux (Red Hat Linux 3.3.3-7) and the Ctrl key works in a weird way:

- Ctrl+3 does what Ctrl+O should

- Ctrl+8 acts like backspace


What I want most is to be able to switch among column presets (Ctrl+1-9, Ctrl+-). I'm accessing this Linux box through PuTTY and have tried every option in the Keyboard settings, but nothing worked.


Also, Shift+arrows does not work in editor. This is critical: there is no way to mark text! Ctrk+K,B appears to work, but Ctrl+K,E doesn't (it produces Ctrl+E).


Any ideas?

Share this post

Link to post
Share on other sites

hey dan!


nope, no ideas at all


fact is: X has almost no support for complex terminal programms, when it comes to keyboard reconfiguration

which means, about 95% of the keyboard hotkeys are completely useless under a terminal


NDN LNX is only really usable in the real linux console


i have no idea how to change that


the ctrl/alt stuff is even worse, because there's no way to read them at all (look at the statusline when pressing alt, shift or ctrl)


we would have to think about completely new hotkeys for the linux terminals

and as long as there's no possibility to completely configure NDN hotkeys via a config file this is useless IMO



Stefan / AH

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this